1

Topic: Error message during correlation

Hello,

while running the correlation, a COSI-Corr user experienced a system error which stated:
"CORRELATION_IMG --> Subscript range values ot the form low:high must be >= 0, < size, with low <= high: MASTER."

The reason of such error is usually to be found among the three following causes:
- non-overlapping images. The overlap is cartographically based, i.e., images must overlap geographically and not only "visually".
- a too small overlapping area between the images. For exemple if you choose a correlation window of 64x64 pixels, the overlapping area needs to
be at least of 128x128 pixels.
- an improper configuration of ENVI. In the ENVI File -> Preferences -> Miscellaneous,  make sure you have the Cache size of at least 300 MB, and and Image Tile Size around  40.00MB. You can refer to the COSI-Corr manual section 2.2.

So if you're running into the same error, make sure that each point above is verified.

Regards,
Francois

PS: Do not hesitate to post your error messages or questions on the forum so each of us can learn and profit from it....

2

Re: Error message during correlation

Hi, I ' trying to do the correlation and I have the following error:

CORRELATION_IMG --> images cannot be overlapped due to their origin and resolution

Both images are in UTM 18 s WGS 84 - w and y start at 1 inn the header. It is a subset of an ASTER image of 24 * 24 km . The orthorectification and resampling went ok.

Cache size is ok with the settings proposed.

I 'm trying to monitor the advance o f a glacier near an active volcanic area.


Many thanks

Pablo

3

Re: Error message during correlation

Dear Pablo,

When you define the orthorectification grid, you have to click on the button "adjust grid to multiple of resolution". Otherwise images may be created on shifted grids, and this shift will render the correlation invalid, hence the error message. You have to re-run your ortho/resampling and make sure that the grid is properly adjusted.

Let us know,
Sebastien

4

Re: Error message during correlation

Dear François,

I had re-run the ortho/res process following your instruction, but still got the same error mesasage.
I am using an SRTM DEM with the same projection  (UTM 18 S -WGS84).
Maybe the coarse resolution (90 m) of the DEM in comparison witrh ASTER (15) is giving me some troubles?

Orthorectification and co-registration of the data looks perfect when linking displays.
My pre-event ASTER image is a slightly westward pass in relation with the post event (1 month between the two passes).
I'll start from the scratch again, maybe I'm using the wrong GCP file?, should I use the optimized GCP file or just the GCPS?

Thanks a lot.

Best wishes,
Pablo

5

Re: Error message during correlation

Dear Pablo,

Your problem is independent of the DEM you are using or the selection of GCPs. Make sure that:

- Both images are defined on the same UTM zone (if one image is at the limit of a UTM zone, it might be a pb)
- Both images are orthorectified with the same resolution (15m I suppose)
- You have adjusted the image coordinates to multiple of image resolution for both images (you can check this in the Map Info of your file, check that the UL Map are divisible by the pixel resolution)

Please open the header file of your ortho-images in a text editor an copy it's content on the forum.

Best,
Sebastien

6

Re: Error message during correlation

Dear Sebastien,

thank you very much for all your help!

Well, I was doing a wrong step trying to correlate my second orto-image with the one I used for reference and not the L1A pre-event.
Now I have produced the 2 images (pre-post event) and  they are ready to correlate, so no more error message. ;-)

I'll let you now how I'm doing with the further processes.

Thanks a lot one more time.

Best wishes,

Pablo

7

Re: Error message during correlation

Hello Sebastien,

I have orthorectified two ASTER images with Cosi-Corr using grided output but while correlation i get this message
CORRELATION_IMG---> Subscript range values of the form low:high must be > =0,size, withlow<=high:MASTER
Please give the solution for this. and wht may be the cause.

8

Re: Error message during correlation

Increase cache size and tile size in Envi preferences, details at the beginning of the COSI-Corr manual.

Sebastien